Продукты Р7
Корпоративный сервер 2024
Корпоративный сервер 2024
Сервер документов
Сервер документов
Редакторы документов
Редакторы документов
Корпоративный сервер 2019
Корпоративный сервер 2019
Графика
Графика
ВКС и мессенджер
ВКС и мессенджер
Мобильные редакторы
Мобильные редакторы
Почтовый сервер
Почтовый сервер
Органайзер
Органайзер
Сервер лицензирования
Сервер лицензирования
Файл-Экспресс
Файл-Экспресс
Аналитика
Аналитика
Дополнительно
Часто задаваемые вопросы
Разработчикам
Интеграции
Новые возможности

Таблицы

Обновлено: 14.08.26

Инструкция актуальна для версии продукта: 2026.3.1.3296

Все версии инструкции (2)

Вставка таблицы

Для вставки таблицы в текст документа:

1. Установите курсор там, где требуется разместить таблицу.

2. На вкладке Вставка нажмите кнопку Таблицы Таблица.

3. В раскрывшемся окне выберите вид таблицы. Возможные варианты:

  • Таблица со стандартным количеством ячеек (максимум 10 на 8 ячеек);
  • Пользовательская таблица (произвольное количество строк и столбцов);
  • Нарисовать таблицу (таблица, нарисованная карандашом, может содержать строки и столбцы разного размера);
  • Преобразовать текст в таблицу (преобразование существующего текста в таблицу);
  • Вставить таблицу (вставка таблицы из встроенного редактора таблиц в качестве OLE-объекта).
Меню кнопки «Таблица» на вкладке «Вставка»

Вставка таблицы со стандартным количеством ячеек

Для вставки таблицы со стандартным количеством ячеек нажмите кнопку Таблицы Таблица и выделите мышью нужное количество строк (до 8) и столбцов (до 10):

Выбор стандартного количества ячеек таблицы в сетке

Вставка пользовательской таблицы

Для вставки пользовательской таблицы (если требуется таблица больше, чем 10 на 8 ячеек) нажмите кнопку Таблицы Таблица и выполните команду Пользовательская таблица. В открывшемся окне введите нужное количество строк и столбцов и нажмите кнопку OK:

Окно «Вставка таблицы» (пользовательская таблица)

Вставка нарисованной таблицы

Вы можете нарисовать таблицу с помощью мыши. Эта опция позволяет создать таблицу со строками и столбцами разного размера.

Чтобы нарисовать таблицу:

1. Нажмите кнопку Таблицы Таблица и выполните команду Нарисовать таблицу.

2. Курсор мыши превратится в карандаш Таблицы. Нарисуйте прямоугольную фигуру там, где требуется добавить таблицу, затем добавьте строки, рисуя горизонтальные линии, и столбцы, рисуя вертикальные линии внутри контура таблицы.

3. Для выхода из режима рисования щелкните за пределами таблицы.

Вставка таблицы из встроенного редактора таблиц (OLE-объект)

Чтобы вставить таблицу с помощью инструментов редактора таблиц, нажмите кнопку Таблицы Таблица и выполните команду Вставить таблицу.

Откроется модальное окно, в котором можно ввести данные и отформатировать их, используя инструменты редактора таблиц, такие как выбор шрифта, типа и стиля, настройка числового формата, вставка функций, форматирование таблицы и так далее.

После внесения данных нажмите кнопку Сохранить и выйти:

Окно встроенного редактора таблиц для вставки OLE-объекта
Важно

Вы также можете вставить файл с таблицей как объект ↗ в виде иконки или миниатюры.

Изменение области отображения таблицы

Область отображения таблицы, вставленной как OLE-объект, можно редактировать:

  • Выбрать фрагмент таблицы, который будет виден в документе. Остальные данные не удаляются — они скрываются, но будут видны при открытии сохраненной таблицы по двойному щелчку мыши;
  • Можно отобразить только ключевые столбцы или строки таблицы, итоговые значения или заголовки.

Все изменения, которые будут внесены в исходную таблицу, будут автоматически отображаться в документе, но только в пределах заданной видимой области.

Для просмотра и изменения области отображения таблицы:

1. Во встроенном редакторе таблиц, на вкладке Вид нажмите кнопку Таблицы Видимая область.

2. Для просмотра отображаемой области выполните команду Показать видимую область. Отобразится видимая область, выделенная голубой рамкой. Чтобы скрыть видимую область, выберите Скрыть видимую область.

Отображение видимой области таблицы во встроенном редакторе

3. Для редактирования видимой области выберите пункт Редактировать видимую область. Отобразится видимая область, выделенная голубой рамкой. Потяните за край голубой рамки, чтобы обрезать видимую область. Вы также можете перемещать видимую область, перетаскивая рамку:

Редактирование границ видимой области таблицы

4. Нажмите кнопку Готово.

5. Чтобы закрыть окно редактора таблиц, нажмите кнопку Сохранить и выйти.

Редактирование таблицы, вставленной как OLE-объект

Для редактирования таблицы, вставленной как OLE-объект, дважды щелкните по ней мышью. Внесите изменения и нажмите кнопку Сохранить и выйти.

Внесенные изменения отображаются в пределах заданной видимой области.

Удаление таблицы, вставленной как OLE-объект

Чтобы удалить таблицу, выделите ее щелчком мыши и нажмите клавишу Delete.

Вставить таблицу как изображение

Вставка таблицы в виде изображения ↗ позволяет защитить ее данные от изменений и зафиксировать внешний вид — сложная структура, уникальные шрифты и формулы гарантированно не изменятся при просмотре документа на любом устройстве. К таблице-рисунку можно применить любые стили обтекания, свободно двигать ее мышью по странице, масштабировать и накладывать на другие объекты, что недоступно для стандартных таблиц.

Чтобы вставить таблицу как изображение:

1. Скопируйте таблицу из редактора таблиц.

2. В текстовом редакторе установите курсор в то место, куда нужно вставить таблицу.

3. Выполните одно из следующих действий:

  • На вкладке Главная нажмите на Таблицы справа от кнопки Таблицы Вставить и выполните команду Вставить как изображение:
Команда «Вставить как изображение» в меню кнопки «Вставить»
  • Щелчком правой кнопки мыши откройте контекстное меню и выполните команду Вставить → Вставить как изображение;
  • Вставьте таблицу стандартным способом (например, с помощью сочетания клавиш Ctrl+V), затем нажмите на появившуюся кнопку Специальная вставка ↗ и выполните команду Вставить как изображение.
Команда «Вставить как изображение» в контекстном меню
Важно

Связь с исходными данными таблицы не сохраняется — обновление данных в таблице не приводит к изменению вставленного изображения.

Преобразование текста в таблицу

Если вы хотите преобразовать текст в таблицу:

1. Выделите текст, который нужно преобразовать в таблицу.

2. Нажмите кнопку Таблицы Таблица и выполните команду Преобразовать текст в таблицу.

3. В окне Преобразовать текст в таблицу, в области Размер таблицы выберите необходимое количество столбцов и строк, в которые вы хотите поместить текст.

4. В области Автоподбор ширины столбцов выберите нужную опцию, чтобы настроить поведение подгонки текста:

  • Фиксированная ширина столбца — по умолчанию установлено значение Авто. Для изменения воспользуйтесь кнопками со стрелками или введите значение вручную;
  • Автоподбор по содержимому — ширина столбца соответствует длине текста;
  • Автоподбор по ширине окна — ширина столбца соответствует ширине страницы.

5. Выберите Разделитель текста: Абзацы, Табуляция, Точки с запятыми или Другой (введите желаемый разделитель вручную).

6. Нажмите кнопку ОК.

Окно «Преобразовать текст в таблицу»

Изменение размера и положения таблицы

Для изменения размера таблицы наведите курсор мыши на маркер в правом нижнем углу и перетаскивайте его, пока таблица не достигнет нужного размера:

Маркер изменения размера таблицы в правом нижнем углу

Чтобы изменить ширину столбца, наведите курсор мыши на его правую границу. Курсор превратится в двунаправленную стрелку Таблицы. Перетащите границу влево или вправо, чтобы задать нужную ширину.

Чтобы изменить высоту строки, наведите курсор мыши на ее нижнюю границу. Курсор превратится в двунаправленную стрелку Таблицы. Перетащите границу вверх или вниз.

Чтобы переместить таблицу, зажмите маркер Таблицы в левом верхнем углу и перетащите таблицу на нужное место в документе.

Выделение таблицы и ее элементов

Для выбора всей таблицы или ее элементов используйте следующие действия:

  • Вся таблица — нажмите на маркер Таблицы в левом верхнем углу;
  • Ячейка — подведите курсор к левому нижнему углу ячейки, чтобы он принял вид Таблицы, и щелкните левой кнопкой мыши;
  • Строка — подведите курсор к левой границе нужной строки, чтобы он принял вид Таблицы, и щелкните левой кнопкой мыши;
  • Столбец — подведите курсор к верхней границе нужного столбца, чтобы он принял вид Таблицы, и щелкните левой кнопкой мыши.

Можно также выделить ячейку, строку, столбец или таблицу с помощью команд контекстного меню или раздела Строки и столбцы на правой боковой панели.

Для перемещения по таблице можно использовать сочетания клавиш ↗.

Стиль обтекания таблицы

Для таблиц доступны два стиля обтекания текстом: Встроенная таблица и Плавающая таблица.

Чтобы изменить стиль обтекания:

1. Откройте окно Таблица — дополнительные параметры одним из следующих способов:

  • Выделите таблицу. На правой боковой панели нажмите кнопку Таблицы Параметры таблицы. На открывшейся панели нажмите Дополнительные параметры;
  • Щелчком правой кнопки мыши по таблице откройте контекстное меню и выполните команду Дополнительные параметры таблицы.

2. В окне Таблица — дополнительные параметры выберите раздел Обтекание текстом.

3. Выберите способ размещения таблицы относительно текста:

  • Таблицы Встроенная таблица — таблица будет являться частью текста;
  • Таблицы Плавающая таблица — текст будет обтекать таблицу со всех сторон.

4. Для встроенной таблицы укажите способ выравнивания (по левому краю, по центру, по правому краю) и отступ слева.

5. Для плавающей таблицы укажите расстояние до текста (сверху, снизу, слева и справа) и положение таблицы (см. описание вкладки Положение таблицы в разделе Параметры таблицы).

6. Нажмите кнопку ОК.

Вкладка «Обтекание текстом» в окне «Таблица — дополнительные параметры»

Параметры таблицы

Параметры таблицы можно изменить с помощью контекстного меню, панели Параметры таблицы или окна Таблица — дополнительные параметры.

Контекстное меню

Чтобы открыть контекстное меню таблицы, щелкните по ней правой кнопкой мыши:

Контекстное меню таблицы

Стандартные операции и печать

  • Вырезать, копировать, вставить — базовые команды для вырезания, копирования и вставки выделенного текста или объекта в позицию курсора;
  • Напечатать выделенное — открыть диалоговое окно для настройки и печати выбранных ячеек;
  • Выделить — выделить текущую строку, столбец, ячейку или всю таблицу.

Добавление элементов таблицы

Команда Добавить используется для вставки новых строк и столбцов:

  • Столбец слева — вставляет новый столбец слева от текущего;
  • Столбец справа — вставляет новый столбец справа от текущего;
  • Строку выше — добавляет строку над текущей строкой;
  • Строку ниже — добавляет строку под текущей строкой;
  • Несколько строк/столбцов — открывает окно для указания количества и направления вставки: над/под курсором для строк или слева/справа для столбцов.
Подменю команды «Добавить» в контекстном меню таблицы

Удаление элементов таблицы

Команда Удалить используется для удаления строки, столбца, таблицы или ячеек:

  • Строку — удаляет строку, в которой установлен курсор;
  • Столбец — удаляет столбец, в котором установлен курсор;
  • Таблицу — удаляет текущую таблицу;
  • Ячейки — открывает окно Удалить ячейки с выбором действия: удалить со сдвигом влево, удалить всю строку или удалить весь столбец.
Подменю команды «Удалить» в контекстном меню таблицы

Изменение структуры ячеек

Команда Объединить ячейки доступна при выделении двух или более ячеек и используется для их объединения.

Также можно объединить ячейки, очистив границу между ними с помощью инструмента Ластик. Для этого на вкладке Вставка нажмите кнопку Таблицы Таблица и выполните команду Очистить таблицу. Курсор мыши превратится в ластик Таблицы. Наведите курсор мыши на границу между ячейками, которые требуется объединить, и очистите ее. Ластик сотрет линии между ячейками, содержимое останется:

Объединение ячеек таблицы с помощью инструмента «Ластик»

Команда Разделить ячейку открывает окно для указания количества строк и столбцов, на которое разделится ячейка.

Также можно разделить ячейку, нарисовав строки или столбцы с помощью инструмента Карандаш. Для этого на вкладке Вставка нажмите кнопку Таблицы Таблица и выполните команду Нарисовать таблицу. Курсор мыши превратится в карандаш Таблицы. Нарисуйте горизонтальную линию для создания строки или вертикальную линию для создания столбца:

Разделение ячейки таблицы с помощью инструмента «Карандаш»
Уточнение

Операции Выделить, Добавить, Удалить, Объединить ячейки и Разделить ячейку доступны также на панели Параметры таблицы, в группе параметров Строки и столбцы (см. ниже).

Выравнивание и ориентация

  • Выровнять высоту строк — делает высоту всех выделенных строк одинаковой без изменения общих габаритов таблицы;
  • Выровнять ширину столбцов — делает ширину всех выделенных столбцов одинаковой без изменения общих габаритов таблицы;
  • Вертикальное выравнивание в ячейках — выравнивает текст внутри выбранных ячеек по верхнему краю, середине или нижнему краю;
  • Направление текста — меняет ориентацию текста в ячейке: по горизонтали, по вертикали сверху вниз (Повернуть текст вниз), или по вертикали снизу вверх (Повернуть текст вверх).

Дополнительные элементы и параметры

  • Вставить название — добавить подпись ↗ к таблице;
  • Дополнительные параметры таблицы — открыть окно Таблица — дополнительные параметры (см. ниже);
  • Добавить комментарий — добавить комментарий к содержимому ячейки, в которой установлен курсор, или к выделенным ячейкам;
  • Гиперссылка — вставить гиперссылку ↗;
  • Дополнительные параметры абзаца — открыть окно Абзац — дополнительные параметры.

Панель Параметры таблицы

Чтобы открыть панель Параметры таблицы:

1. Выделите таблицу.

2. На правой боковой панели нажмите кнопку Таблицы Параметры таблицы.

Параметры строк и столбцов

Параметр Строки позволяет применять специальное форматирование к определенным строкам таблицы:

  • Заголовок — выделяет первую строку как заголовок таблицы (например, жирным шрифтом или другим цветом фона);
  • Итоговая — добавляет строку Итого в нижней части таблицы. При выборе этой опции можно указать функцию для вычисления суммарных значений;
  • Чередовать — включает чередование цвета фона для четных и нечетных строк.

Параметр Столбцы позволяет применять специальное форматирование к определенным столбцам таблицы:

  • Первый — применяет особое форматирование к крайнему левому столбцу, например, когда в первом столбце находятся названия категорий;
  • Последний — выделяет крайний правый столбец, например, если в нем находятся итоговые значения;
  • Чередовать — включает чередование цвета фона для четных и нечетных столбцов.
Параметры строк и столбцов на боковой панели параметров таблицы

Работа с шаблонами оформления

Параметр По шаблону позволяет быстро применить к таблице готовый стиль оформления — набор заранее подобранных параметров форматирования:

  • цвет фона ячеек (в том числе чередующийся);
  • стиль и цвет границ;
  • начертание и цвет шрифта;
  • выравнивание текста;
  • другие визуальные эффекты.

Список доступных шаблонов зависит от настроек параметров Строки и Столбцы. Например: если для строк установлены флажки Заголовок и Чередовать, то в списке будут отображаться только те шаблоны, которые поддерживают эти опции. Для сброса текущего стиля (очистки цвета фона, границ и т.  д.) без удаления таблицы можно выбрать шаблон Normal Table — таблица станет базовой, но сохранит структуру данных:

Галерея шаблонов оформления на боковой панели параметров таблицы

Управление элементами таблицы

  • Стиль границ — выбор толщины, цвета и стиля линий границ, а также цвета фона таблицы;
  • Строки и столбцы — инструменты для выделения, вставки и удаления элементов, а также для объединения и разделения ячеек. Эти команды дублируют команды контекстного меню (см. выше);
  • Размеры строк и столбцов — используется для изменения ширины и высоты выделенной ячейки. В этом разделе можно также Выровнять высоту строк, чтобы все выделенные ячейки имели одинаковую высоту, или Выровнять ширину столбцов, чтобы все выделенные ячейки имели одинаковую ширину;
  • Добавить формулу — вставка математической формулы ↗ в выбранную ячейку;
  • Повторять как заголовок на каждой странице — автоматически дублирует строку заголовка вверху каждой страницы для длинных таблиц;
  • Дополнительные параметры — открывает окно Таблица — дополнительные параметры (см. ниже).

Окно Таблица — дополнительные параметры

Чтобы открыть окно Таблица — дополнительные параметры, выполните одно из следующих действий:

  • Выделите таблицу. На правой боковой панели нажмите кнопку Таблицы. На панели Параметры таблицы нажмите Дополнительные параметры;
  • Щелчком правой кнопки мыши по таблице откройте контекстное меню и выполните команду Дополнительные параметры таблицы.

Измените необходимые свойства на вкладках:

  • Таблица — базовые настройки таблицы (ширина, поля ячейки по умолчанию, интервалы между ячейками);
  • Ячейка — настройки для отдельных ячеек (ширина, поля, перенос текста);
  • Границы и фон — управление внешним видом таблицы (стиль и цвет границ, заливка фоном ячеек, таблицы и интервалов между ячейками);
  • Положение таблицы — вкладка доступна при выборе стиля обтекания текстом Плавающая таблица, определяет положение таблицы на странице и опции ее перемещения;
  • Обтекание текстом — взаимодействие таблицы с окружающим текстом;
  • Альтернативный текст — альтернативное текстовое представление.

Нажмите ОК для сохранения изменений:

Окно «Таблица — дополнительные параметры»

Вкладка Таблица

На вкладке Таблица можно изменить свойства всей таблицы.

Параметры вкладки Таблица:

  • Ширина — размер всей таблицы. По умолчанию таблица автоматически растягивается на все пространство между левым и правым полями страницы. Чтобы задать точную ширину вручную, установите флажок Ширина;
  • Единицы — формат измерения ширины таблицы. Можно выбрать Проценты (от общей ширины страницы) или абсолютные единицы: Сантиметры, Пункты или Дюймы (единицы измерения настраиваются на вкладке Файл → Дополнительные параметры).
Важно

Размеры таблицы можно менять вручную. Наведите курсор на границу строки или столбца до появления двусторонней стрелки (Таблицы или Таблицы) и перетащите границу. Также для регулировки ширины столбцов можно использовать маркеры Таблицы на горизонтальной линейке, а для высоты строк — маркеры Таблицы на вертикальной линейке.

  • Автоподбор размеров по содержимому — функция, которая автоматически подгоняет ширину каждого столбца под объем текста внутри его ячеек;
  • Поля ячейки по умолчанию — позволяет настроить стандартные отступы между текстом и внутренними границами ячеек для всей таблицы;
  • Интервалы между ячейками — активирует свободное пространство (зазоры) между ячейками. Чтобы задать расстояние, установите флажок и введите нужное значение.
Уточнение

При заливке ячеек цветом интервалы между ними остаются прозрачными или белыми, создавая визуальный эффект сетки. Чтобы раскрасить сами интервалы, задайте фоновый цвет для всей таблицы на вкладке Границы и фон (он должен отличаться от цвета ячеек).

Вкладка «Таблица» в окне «Таблица — дополнительные параметры»

Вкладка Ячейка

На вкладке Ячейка можно изменить свойства отдельных ячеек. Выберите ячейку, к которой требуется применить изменения, или выделите всю таблицу, чтобы изменить свойства всех ее ячеек.

Вкладка Ячейка содержит следующие параметры:

  • Ширина — предпочтительная ширина ячейки. Если текст превышает заданное значение, он переносится на новую строку. Однако при добавлении новых столбцов эта ширина может автоматически уменьшиться. Чтобы активировать параметр, установите флажок Ширина;
  • Единицы — формат измерения ширины. Доступны Проценты (от общей ширины страницы) или абсолютные единицы: Сантиметры, Пункты или Дюймы (единицы измерения настраиваются на вкладке Файл → Дополнительные параметры).
Важно

Ширину ячейки можно менять вручную. Выделите нужные ячейки, наведите курсор на их правую границу до появления двусторонней стрелки Таблицы и перетащите ее. При этом изменится только размер выбранных ячеек, а общая ширина столбца останется прежней. Также для регулировки можно использовать маркеры Таблицы на горизонтальной линейке.

  • Поля ячейки — расстояние между текстом и внутренними границами ячейки. По умолчанию система использует стандартные настройки таблицы. Чтобы задать собственные отступы, снимите флажок Использовать поля по умолчанию и введите значения вручную. Поля ячейки можно также настроить на вкладке Таблица (см. выше);
  • Перенос текста — функция автоматического переноса длинного текста на новую строку. Она сохраняет заданную ширину столбца, увеличивая только высоту строки.
Вкладка «Ячейка» в окне «Таблица — дополнительные параметры»

Вкладка Строка

На вкладке Строка вы можете запретить перенос части длинного абзаца на следующий лист. Когда параметр отключен, абзац внутри ячейки не разделяется и при нехватке места на странице переходит на новый лист целиком. По умолчанию параметр включен:

Вкладка «Строка» в окне «Таблица — дополнительные параметры»

Перенос настраивается для каждой строки таблицы отдельно. Чтобы изменить этот параметр:

1. Установите курсор в нужную строку таблицы.

2. Откройте окно Таблица — дополнительные параметры и перейдите на вкладку Строка.

3. Снимите флажок Разрешить перенос строки на следующую страницу, чтобы запретить перенос.

Если необходимо настроить этот параметр для другой строки, используйте кнопки Таблицы Предыдущая строка и Таблицы Следующая строка. Номер выбранной строки отображается над флажком Разрешить перенос строки на следующую страницу:

Настройка параметров переноса строки таблицы на следующую страницу

Вкладка Границы и фон

Вкладка Границы и фон содержит следующие параметры:

  • Ширина границ — толщина границ или их отсутствие;
  • Цвет границ — цвет ↗ линий. Чтобы применить выбранный стиль, используйте кнопки с типами границ или щелкайте мышью прямо по схеме.
Вкладка «Границы и фон» в окне «Таблица — дополнительные параметры»
Уточнение

Если скрыть границы таблицы с помощью кнопки Таблицы или схемы, в документе они будут отображаться пунктиром. Для их полного сокрытия нажмите на стрелку рядом с кнопкой Непечатаемые символы на вкладке Главная и снимите флажок Скрытые границы таблиц.

  • Фон ячейки — цвет заливки внутри ячеек. Параметр доступен, если выделена одна или несколько ячеек или включена настройка Интервалы между ячейками на вкладке Таблица;
  • Фон таблицы — цвет заливки всей таблицы или пространства между ячейками, если на вкладке Таблица включена настройка Интервалы между ячейками.
Настройка цвета фона ячейки и таблицы на вкладке «Границы и фон»

Пример внешнего вида таблицы с настроенным интервалом и цветом фона между ячейками представлен на рисунке ниже:

Пример таблицы с настроенным интервалом и цветом фона между ячейками

Вкладка Положение таблицы

Вкладка Положение таблицы доступна только в том случае, если на вкладке Обтекание текстом (см. ниже) выбран параметр Плавающая таблица.

Вкладка Положение таблицы содержит следующие параметры:

  • Параметры раздела По горизонтали включают в себя выравнивание таблицы (по левому краю, по центру, по правому краю) относительно поля, страницы или текста, а также положение таблицы справа от поля, страницы или текста;
  • Параметры раздела По вертикали включают в себя выравнивание таблицы (по верхнему краю, по центру, по нижнему краю) относительно поля, страницы или текста, а также положение таблицы ниже поля, страницы или текста.
Вкладка «Положение таблицы» в окне «Таблица — дополнительные параметры»
  • Перемещать с текстом — перемещать таблицу вместе с текстом, в который она вставлена;
  • Разрешить перекрытие — позволяет накладывать таблицы друг на друга при их сближении на странице. Если при перетаскивании необходимо объединить две таблицы в одну общую, снимите этот флажок (в результате увеличится количество строк или столбцов).

Вкладка Обтекание текстом

Вкладка Обтекание текстом содержит следующие параметры:

  • Стиль обтекания — определяет способ размещения таблицы относительно текста: Таблицы Встроенная таблица (таблица является частью текста) или Таблицы Плавающая таблица (текст обтекает таблицу со всех сторон);
  • Для встроенных таблиц: Выравнивание по левому краю, по центру, по правому краю и Отступ слева.
Вкладка «Обтекание текстом» для встроенной таблицы
  • Для плавающих таблиц: Расстояние до текста (сверху, снизу, слева и справа):
Настройка расстояния до текста для плавающей таблицы

Вкладка Альтернативный текст

Вкладка Альтернативный текст позволяет указать Заголовок и Описание, которые будут зачитываться для людей с нарушениями зрения или когнитивными нарушениями, чтобы помочь им лучше понять, какую информацию содержит таблица:

Вкладка «Альтернативный текст» в окне «Таблица — дополнительные параметры»

Использование формул в таблицах

Вставка формулы

Вы можете выполнять простые вычисления с данными в ячейках таблицы с помощью формул. Для вставки формулы в ячейку таблицы:

1. Установите курсор в ячейке, где требуется отобразить результат.

2. На правой боковой панели нажмите кнопку Таблицы Параметры таблицы. На открывшейся панели нажмите кнопку Добавить формулу:

Кнопка «Добавить формулу» на боковой панели параметров таблицы

3. В окне Настройки формулы выполните одно из следующих действий:

  • Введите нужную формулу в поле Формула, используя математические операторы (+, -,*, /), например, =A1B2;
  • В выпадающем списке Вставить функцию выберите встроенную функцию, например, =PRODUCT(A1,B2).
Окно «Настройки формулы»

4. При необходимости в поле Формула задайте аргументы функции в скобках (если аргументов несколько, разделяйте их запятыми). В качестве аргументов можно использовать:

  • ссылки на отдельные ячейки (например, A1);
  • диапазоны ячеек (например, A1:A3);
  • абсолютные ($A$1) или относительные (A1) ссылки.

5. В выпадающем списке Формат числа выберите формат, если требуется отобразить результат в определенном числовом формате.

6. Нажмите кнопку OK.

Результат будет отображен в выбранной ячейке.

Работа с диапазонами и ссылками

Для работы с диапазонами используйте обозначения:

  • A:A — весь столбец A;
  • 1:1 — вся строка 1;
  • A1:A3 — диапазон ячеек от A1 до A3.

Типы ссылок:

  • Абсолютные ссылки (с символом $) — фиксируют адрес ячейки при копировании формулы (например, $A$1);
  • Относительные ссылки — автоматически изменяются при копировании формулы (например, A1).

Примеры встроенных функций

  • ABS(x) — модуль числа;
  • AVERAGE(argument-list) — среднее значение;
  • COUNT(argument-list) — подсчет ячеек с числами;
  • IF(logical_test, value_if_true, value_if_false) — условная проверка;
  • SUM(A1:B7) — сумма диапазона.

Полное описание встроенных функций см. в таблице ниже.

Редактирование формулы и обновление результатов

Для редактирования добавленной формулы:

1. Выделите результат в ячейке.

2. Нажмите кнопку Добавить формулу на правой боковой панели.

3. Внесите нужные изменения в окне Настройки формулы.

4. Нажмите кнопку OK.

Для обновления результата формулы после изменения данных в ячейках:

1. Выделите результат.

2. Выполните одно из следующих действий:

  • Нажмите клавишу F9;
  • Щелчком правой кнопки мыши откройте контекстное меню и выполните команду Обновить поле.

Чтобы обновить результаты нескольких формул, выделите нужные ячейки или всю таблицу и нажмите клавишу F9.

Добавление ссылок на ячейки

Чтобы быстро добавить ссылки на диапазоны ячеек, используйте следующие аргументы:

  • ABOVE — ссылка на все ячейки в столбце, расположенные выше выделенной ячейки;
  • LEFT — ссылка на все ячейки в строке, расположенные слева от выделенной ячейки;
  • BELOW — ссылка на все ячейки в столбце, расположенные ниже выделенной ячейки;
  • RIGHT — ссылка на все ячейки в строке, расположенные справа от выделенной ячейки.

Эти аргументы можно использовать с функциями AVERAGE, COUNT, MAX, MIN, PRODUCT, SUM.

Также можно вручную вводить ссылки на определенную ячейку (например, A1) или диапазон ячеек (например, A1:B3).

Использование закладок

Если вы добавили закладки ↗ на ячейки в таблице, при вводе формул можно использовать эти закладки в качестве аргументов:

1. В окне Настройки формулы, в поле Формула установите курсор в то место внутри скобок, где требуется добавить аргумент.

2. Разверните выпадающий список Вставить закладку и выберите одну из ранее добавленных закладок.

Встроенные функции

Можно использовать следующие стандартные математические, статистические и логические функции:

КатегорияФункцияОписаниеПрименение
МатематическиеABS(x)Функция используется для нахождения модуля (абсолютной величины) числа=ABS(-10)
Возвращает 10
ЛогическиеAND(logical1, logical2,…)Функция используется для проверки, является ли введенное логическое значение истинным или ложным. Функция возвращает значение 1 (ИСТИНА), если все аргументы имеют значение ИСТИНА=AND(1>0,1>3)
Возвращает 0
СтатистическиеAVERAGE(argument-list)Функция анализирует диапазон данных и вычисляет среднее значение=AVERAGE(4,10)
Возвращает 7
СтатистическиеCOUNT(argument-list)Функция используется для подсчета количества ячеек в выбранном диапазоне, содержащих числа, без учета пустых или содержащих текст ячеек=COUNT(A1:B3)
Возвращает 6
ЛогическиеDEFINED()Функция оценивает, определено ли значение в ячейке. Функция возвращает 1, если значение определено и вычисляется без ошибок, и возвращает 0, если значение не определено или вычисляется с ошибкой=DEFINED(A1)
ЛогическиеFALSE()Функция возвращает значение 0 (ЛОЖЬ) и не требует аргумента=FALSE
Возвращает 0
ЛогическиеIF(logical_test, value_if_true, value_if_false)Функция используется для проверки логического выражения и возвращает одно значение, если проверяемое условие имеет значение ИСТИНА, и другое, если оно имеет значение ЛОЖЬ=IF(3>1,1,0)
Возвращает 1
МатематическиеINT(x)Функция анализирует и возвращает целую часть заданного числа=INT(2.5)
Возвращает 2
СтатистическиеMAX(number1, number2,…)Функция используется для анализа диапазона данных и поиска наибольшего числа=MAX(15,18,6)
Возвращает 18
СтатистическиеMIN(number1, number2,…)Функция используется для анализа диапазона данных и поиска наименьшего числа=MIN(15,18,6)
Возвращает 6
МатематическиеMOD(x, y)Функция возвращает остаток от деления числа на заданный делитель=MOD(6,3)
Возвращает 0
ЛогическиеNOT(logical)Функция используется для проверки, является ли введенное логическое значение истинным или ложным. Функция возвращает значение 1 (ИСТИНА), если аргумент имеет значение ЛОЖЬ, и 0 (ЛОЖЬ), если аргумент имеет значение ИСТИНА=NOT(2<5)
Возвращает 0
ЛогическиеOR(logical1, logical2,…)Функция используется для проверки, является ли введенное логическое значение истинным или ложным. Функция возвращает значение 0 (ЛОЖЬ), если все аргументы имеют значение ЛОЖЬ=OR(1>0,1>3)
Возвращает 1
МатематическиеPRODUCT(argument-list)Функция перемножает все числа в заданном диапазоне ячеек и возвращает произведение=PRODUCT(2,5)
Возвращает 10
МатематическиеROUND(x, num_digits)Функция округляет число до заданного количества десятичных разрядов=ROUND(2.25,1)
Возвращает 2.3
МатематическиеSIGN(x)Функция определяет знак числа. Если число положительное, функция возвращает значение 1. Если число отрицательное, функция возвращает значение -1. Если число равно 0, функция возвращает значение 0=SIGN(-12)
Возвращает -1
МатематическиеSUM(argument-list)Функция возвращает результат сложения всех чисел в выбранном диапазоне ячеек=SUM(5,3,2)
Возвращает 10
ЛогическиеTRUE()Функция возвращает значение 1 (ИСТИНА) и не требует аргумента=TRUE
Возвращает 1

Была ли эта статья полезной?

Поделитесь пожалуйста своим мнением

      В статье есть ошибкиРекомендации не помоглиТекст трудно понятьСодержание статьи не соответствует заголовкуДругое