Продукты Р7
Корпоративный сервер 2024
Корпоративный сервер 2024
Сервер документов
Сервер документов
Редакторы документов
Редакторы документов
Корпоративный сервер 2019
Корпоративный сервер 2019
Графика
Графика
ВКС и мессенджер
ВКС и мессенджер
Мобильные редакторы
Мобильные редакторы
Почтовый сервер
Почтовый сервер
Органайзер
Органайзер
Сервер лицензирования
Сервер лицензирования
Файл-Экспресс
Файл-Экспресс
Аналитика
Аналитика
Дополнительно
Часто задаваемые вопросы
Разработчикам
Интеграции
Новые возможности

Элементы управления содержимым

Обновлено: 14.08.26

Инструкция актуальна для версии продукта: 2026.3.1.3296

Все версии инструкции (2)

Создание элемента

В редакторе документов есть возможность создания форм с помощью элементов управления. В зависимости от выбранного типа элемента управления содержимым вы можете создать форму с полями ввода, которую могут заполнять другие пользователи, а также защитить созданные формы от редактирования или удаления.

Редактор документов позволяет вставлять классические элементы управления содержимым, т.е. они обратно совместимы со сторонними текстовыми редакторами.

Доступны следующие элементы управления:

НазваниеНазначение
Обычный текстТекстовое поле ввода. Может содержать не более одного абзаца
Форматированный текстТекстовое поле с расширенными возможностями (поддерживает форматирование текста, добавление списков и объектов). Может содержать несколько абзацев
РисунокГотовая зона вставки (контейнер) для быстрого добавления, масштабирования и выравнивания изображений в шаблоне
Поле со списком ↗Позволяет создать выпадающий список, в котором можно выбрать один из пунктов и отредактировать его значение
Выпадающий списокПозволяет создать выпадающий список, в котором можно выбрать один из пунктов без возможности его редактирования
ДатаПоле со встроенным интерактивным календарем для быстрого и безошибочного выбора нужного числа, месяца и года
ФлажокПозволяет создать чекбоксы с поддержкой множественного выбора. Флажок может быть установлен или снят

Чтобы создать элемент управления:

1. Установите курсор там, где требуется добавить элемент.

2. На вкладке Вставка нажмите кнопку Элементы управления содержимым Элементы управления содержимым.

3. Выберите элемент управления. Элемент будет вставлен в текущей позиции курсора.

4. Настройте элемент так, как описано в разделах ниже.

Обычный текст

Элемент Обычный текст — это текстовое поле ввода. Он не поддерживает разрывы строк и не может содержать другие объекты (например, изображения или таблицы).

Внешний вид элемента после создания представлен на рисунке ниже. Вы можете ввести собственный текст вместо стандартного или вставить его из буфера обмена.

Внешний вид элемента «Обычный текст»

Чтобы настроить элемент Обычный текст, щелкните по нему правой кнопкой мыши и выполните команду контекстного меню Параметры элемента управления содержимым.

Откроется окно Параметры элемента управления содержимым.

Вкладка Общие содержит следующие параметры:

  • Заголовок — текстовая метка, которая отображается над полем ввода. Служит подсказкой для пользователя и поясняет, какие данные необходимо ввести;
  • Заполнитель — вспомогательный текст (плейсхолдер) внутри поля ввода, который подсказывает формат или пример данных. Автоматически исчезает, как только пользователь начинает вводить свой текст в этом поле;
  • Тег — служебная метка для поля ввода, предназначена для идентификации поля при автоматизации. Например, client_name, phone_number. Тег отображается только в режиме редактирования элемента. Пользователь при заполнении его не видит.

Поле Отображать предназначено для настройки внешнего вида границ поля:

  • С ограничивающей рамкой — текстовое поле ввода отображается с рамкой. Рамка видна только при щелчке по полю. В печатной версии рамка не отображается;
  • Без рамки — текстовое поле ввода отображается без рамки как часть обычного текста. Поле активируется (становится доступным для ввода), только если по нему щелкнуть. Используется, если нужно, чтобы форма выглядела как обычный документ, но при этом оставалась редактируемой.
Вкладка «Общие» в окне «Параметры элемента управления содержимым»

В поле Цвет можно выбрать цвет ограничивающей рамки.

Нажмите кнопку Применить ко всем, чтобы текущие настройки форматирования применились ко всем однотипным элементам управления в документе (например, все поля ввода Обычный текст стали отображаться с синей рамкой).

Вкладка Блокировка содержит следующие параметры:

  • Элемент управления содержимым нельзя удалить — установите флажок, если требуется защита данного поля ввода от удаления. При установленном флажке пользователь не сможет удалить поле из документа. Опция позволяет обеспечить наличие обязательных полей на заполняемой форме;
  • Содержимое нельзя редактировать — установите флажок, если требуется защитить содержимое поля от редактирования.
Вкладка «Блокировка» в окне «Параметры элемента управления содержимым»

Для сохранения настроек элемента нажмите кнопку ОК.

Форматированный текст

Элемент Форматированный текст представляет собой текстовое поле ввода, но в отличие от элемента Обычный текст позволяет:

  • создавать несколько абзацев;
  • вставлять маркированные и нумерованные списки;
  • вставлять различные объекты (таблицы, фигуры, изображения, другие элементы управления);
  • форматировать текст внутри поля ввода (шрифты, отступы, интервалы и т.  д.).

После создания элемент Форматированный текст имеет вид, представленный на рисунке.

Внешний вид элемента «Форматированный текст»

Вы можете начать вводить свой текст вместо стандартного текста или скопировать в поле ввода текст, предварительно сохраненный в буфер обмена.

Для настройки элемента Форматированный текст:

1. Щелчком правой кнопки мыши по элементу откройте контекстное меню и выполните команду Параметры элемента управления содержимым.

2. В окне Параметры элемента управления содержимым заполните значения параметров в разделах Общие и Блокировка (см. описание элемента Обычный текст).

3. Нажмите кнопку ОК.

Окно параметров элемента управления содержимым «Форматированный текст»

Пример заполнения пользователем элемента Форматированный текст представлен на рисунке:

Пример заполнения элемента «Форматированный текст»

Рисунок

Элемент Рисунок предназначен для вставки изображений в заполняемые пользователем формы. В отличие от обычной вставки изображения ↗ в документ, он выполняет следующие задачи:

  • позволяет заранее задать место для изображения в шаблоне;
  • предоставляет возможность запретить удаление или редактирование зоны вставки;
  • может иметь рамку и цвет для визуального выделения зоны вставки;
  • Внешний вид элемента после создания представлен на рисунке ниже.
Внешний вид элемента «Рисунок» после создания

При работе с элементом доступны следующие действия:

  • Изменение размера и поворот — щелкните по элементу, чтобы на его границах отобразились маркеры изменения размера, и перетаскивайте их мышью. Для вращения зоны вставки используйте маркер поворота Элементы управления содержимым;
  • Выбор или замена изображения — нажмите на значок Элементы управления содержимым над границей элемента. В открывшемся окне выберите файл на компьютере и нажмите кнопку Открыть.

Для настройки элемента Рисунок:

1. Щелчком правой кнопки мыши по элементу откройте контекстное меню и выполните команду Параметры элемента управления содержимым.

2. В окне Параметры элемента управления содержимым заполните значения параметров в разделах Общие и Блокировка (см. описание элемента Обычный текст).

Важно

Параметр Заполнитель для элемента Рисунок не используется.

3. Нажмите кнопку ОК.

Окно параметров элемента управления содержимым «Рисунок»

Поле со списком

Элемент Поле со списком предназначен для создания выпадающего списка, в котором можно выбрать один из пунктов и отредактировать его значение.

Внешний вид элемента после создания представлен на рисунке ниже.

Внешний вид элемента «Поле со списком» после создания

Для настройки элемента Поле со списком:

1. Щелчком правой кнопки мыши по элементу откройте контекстное меню и выполните команду Параметры элемента управления содержимым.

2. В окне Параметры элемента управления содержимым заполните значения параметров в разделах Общие и Блокировка (см. описание элемента Обычный текст).

3. На вкладке Поле со списком создайте пункты выпадающего списка.

Вкладка «Поле со списком» в окне параметров элемента управления

Чтобы добавить новый пункт списка, нажмите кнопку Добавить.

В открывшемся окне укажите:

  • Отображаемое имя — текст пункта списка;
  • Значение — служебный код для программной обработки. Если не заполнять, будет использовано значение поля Отображаемое имя. Введенное значение должно быть уникальным для каждого пункта списка.

Нажмите кнопку ОК для сохранения пункта списка.

Повторите шаги для всех пунктов списка:

Список добавленных пунктов на вкладке «Поле со списком»

При необходимости измените порядок пунктов с помощью кнопок Вверх и Вниз.

Для удаления пункта списка нажмите кнопку Удалить.

Для редактирования пункта списка нажмите кнопку Редактировать, измените необходимые значения и нажмите ОК.

Для сохранения настроек элемента нажмите кнопку ОК.

Внешний вид готового элемента представлен на рисунке ниже.

Для выбора пункта списка нажмите кнопку Элементы управления содержимым справа от поля, содержащего Заполнитель, и щелкните по нужному пункту:

Выбор пункта в элементе «Поле со списком»

После выбора пункта его значение можно отредактировать. Для этого нужно ввести свой текст вместо выбранного.

Редактирование значения выбранного пункта в элементе «Поле со списком»

Выпадающий список

Элемент Выпадающий список предназначен для создания выпадающего списка, в котором можно выбрать один из пунктов без возможности его редактирования.

Внешний вид элемента после создания представлен на рисунке ниже.

Внешний вид элемента «Выпадающий список»

Для настройки элемента Выпадающий список:

1. Щелчком правой кнопки мыши по элементу откройте контекстное меню и выполните команду Параметры элемента управления содержимым.

2. В окне Параметры элемента управления содержимым заполните значения параметров в разделах Общие, Блокировка и Поле со списком (см. описание элементов Обычный текст и Поле со списком).

3. Нажмите кнопку ОК.

Внешний вид готового элемента представлен на рисунке ниже.

Чтобы выбрать значение, нажмите кнопку Элементы управления содержимым справа от поля, содержащего Заполнитель, и щелкните по нужному варианту. В отличие от элемента Поле со списком отредактировать выбранный вариант нельзя, его можно только выбрать из списка:

Выбор варианта из выпадающего списка

Дата

Элемент Дата предназначен для создания поля выбора даты из календаря. Внешний вид элемента после создания представлен на рисунке ниже.

Внешний вид элемента «Дата» после создания

Для настройки элемента Дата:

1. Щелчком правой кнопки мыши по элементу откройте контекстное меню и выполните команду Параметры элемента управления содержимым.

2. В окне Параметры элемента управления содержимым заполните значения параметров в разделах Общие, Блокировка и Формат даты. Описание параметров в разделах Общие и Блокировка представлено в описании элемента Обычный текст ↗.

3. На вкладке Формат даты выберите язык отображения даты и подходящий формат.

4. Для сохранения настроек элемента нажмите кнопку ОК.

Вкладка «Формат даты» в окне «Параметры элемента управления содержимым»

Внешний вид готового элемента представлен на рисунке ниже:

Календарь для выбора даты в элементе «Дата»

Для выбора даты нажмите кнопку Элементы управления содержимым справа от поля, содержащего Заполнитель, и выберите дату из календаря. Дата отобразится в заданном формате:

Отображение выбранной даты в элементе «Дата»

Флажок

Элемент Флажок предназначен для создания чекбоксов с поддержкой множественного выбора. Элемент может отображаться в двух состояниях: установлен или снят.

Элемент может использоваться для:

  • Бинарного выбора — ответы типа Да/Нет, Согласен/Не согласен;
  • Множественного выбора — добавляется несколько элементов Флажок рядом друг с другом или в списке под общим вопросом. Каждый работает независимо — пользователь может отметить любое количество вариантов.

Каждый элемент Флажок хранит одно из двух значений:

  • установлен (истина/true);
  • снят (ложь/false).

Внешний вид элемента после создания представлен на рисунке ниже.

Для настройки элемента Флажок:

1. Щелчком правой кнопки мыши по элементу откройте контекстное меню и выполните команду Параметры элемента управления содержимым.

Окно «Параметры элемента управления содержимым» для элемента «Флажок»

2. В окне Параметры элемента управления содержимым заполните значения параметров в разделах Общие и Блокировка (см. описание элемента Обычный текст).

3. На вкладке Флажок настройте значки для каждого состояния элемента:

  • Нажмите кнопку Символ установленного флажка, в открывшемся окне выберите нужный символ ↗ и нажмите ОК;
  • Нажмите кнопку Символ снятого флажка, в открывшемся окне выберите нужный символ и нажмите ОК.
Вкладка «Флажок» в окне параметров элемента управления содержимым

4. Для сохранения настроек элемента нажмите кнопку OK.

Готовый элемент отображается в режиме снятого флажка.

Внешний вид элемента «Флажок» в снятом состоянии

При щелчке он отмечается символом, выбранным в списке Символ установленного флажка.

Внешний вид элемента «Флажок» в установленном состоянии

Перемещение элемента

Чтобы переместить элемент управления:

1. Нажмите на кнопку Элементы управления содержимым слева от границы элемента управления.

2. Перетащите элемент на нужное место в документе.

Перемещение элемента управления содержимым за маркер

Для копирования и вставки выделите нужный элемент и используйте стандартные сочетания клавиш Ctrl+C и Ctrl+V.

Выделение элемента цветом

Важно

Выбранный цвет применяется сразу ко всем элементам управления содержимым в документе.

Чтобы выделить цветом не только рамку элемента, но и весь элемент с содержимым:

1. На вкладке Вставка нажмите кнопку Элементы управления содержимым Элементы управления содержимым.

Меню кнопки «Элементы управления содержимым» на вкладке «Вставка»

2. Наведите курсор мыши на команду Цвет подсветки. По умолчанию выбрана опция Без подсветки.

3. Выберите цвет из доступных наборов цветов или задайте цвет самостоятельно. Доступны следующие наборы цветов:

  • Набор стандартных цветов;
  • Недавние цвета — цвета, использованные последними;
  • Другие цвета — раздел позволяет создать свой цвет. Выберите нужный цветовой диапазон, перемещая вертикальный ползунок цвета, и определите конкретный цвет, перетаскивая инструмент для выбора цвета внутри большого цветового поля. Когда вы выберете цвет, в полях справа отобразятся соответствующие цветовые значения RGB и sRGB. Также можно задать цвет на базе цветовой модели RGB, введя нужные числовые значения в полях R, G, B (красный, зеленый, синий), или указать шестнадцатеричный код sRGB в поле, отмеченном знаком #. Выбранный цвет появится в окне предварительного просмотра Новый. Если к объекту был ранее применен какой-то пользовательский цвет, этот цвет отображается в окне Текущий, так что вы можете сравнить исходный и измененный цвета. Когда цвет будет задан, нажмите на кнопку Добавить.
Палитра выбора цвета подсветки элементов управления содержимым

Выбранный цвет будет применен к элементам и добавлен в палитру Недавние цвета.

Пример применения цвета подсветки к элементу управления содержимым

Удаление элемента

Важно

Элемент управления содержимым не будет удален, если в окне Параметры элемента управления содержимым, на вкладке Блокировка установлен флажок Элемент управления содержимым нельзя удалить.

Способ 1

Чтобы удалить только элемент управления, сохранив его содержимое:

1. Выполните одно из следующих действий:

  • Выделите элемент управления щелчком мыши. На вкладке Вставка нажмите кнопку Элементы управления содержимым Элементы управления содержимым;
  • Щелчком правой кнопки мыши по элементу управления откройте контекстное меню.

2. Выполните команду Удалить элемент управления содержимым.

Способ 2

Чтобы удалить и элемент управления, и все его содержимое, выделите элемент и нажмите клавишу Delete.

Была ли эта статья полезной?

Поделитесь пожалуйста своим мнением

      В статье есть ошибкиРекомендации не помоглиТекст трудно понятьСодержание статьи не соответствует заголовкуДругое