Продукты Р7
Корпоративный сервер 2024
Корпоративный сервер 2024
Сервер документов
Сервер документов
Редакторы документов
Редакторы документов
Корпоративный сервер 2019
Корпоративный сервер 2019
Графика
Графика
ВКС и мессенджер
ВКС и мессенджер
Мобильные редакторы
Мобильные редакторы
Почтовый сервер
Почтовый сервер
Органайзер
Органайзер
Сервер лицензирования
Сервер лицензирования
Файл-Экспресс
Файл-Экспресс
Аналитика
Аналитика
Дополнительно
Часто задаваемые вопросы
Разработчикам
Интеграции
Новые возможности

Файл как объект

Обновлено: 14.08.26

Инструкция актуальна для версии продукта: 2026.3.1.3296

Все версии инструкции (2)

Общая информация

Десктопная версия приложения поддерживает интеграцию в документ сторонних файлов в качестве самостоятельных объектов. Эта функция позволяет хранить материалы внутри одного файла и работать с ними без необходимости переключения между разными программами.

Например, при создании методического пособия в документ можно внедрить презентации к лекциям. Студенты или преподаватели смогут скачать их прямо из текста.

Приложение поддерживает внедрение файлов следующих популярных форматов:

  • текстовые документы: DOC, DOCX;
  • электронные таблицы: XLS, XLSX;
  • презентации: PPT, PPTX.

Внедряемые файлы можно отображать в теле документа в виде миниатюр (для предварительного просмотра содержимого) или в виде иконок (для компактного размещения).

При вставке файл полностью интегрируется в структуру текущего документа и становится его частью. Связь с файлом-источником разрывается: изменения во внедренном объекте не отражаются на оригинальном файле, и наоборот.

Вставка объекта в виде миниатюры

Чтобы вставить объект как миниатюру:

1. Установите курсор там, куда требуется вставить объект.

2. Выполните одно из следующих действий:

  • На вкладке Вставка нажмите Файл как объект под кнопкой Файл как объект Объект и выполните команду Вставить объект как миниатюра;
  • На вкладке Вставка нажмите кнопку Файл как объект Объект, если в предыдущий раз вы вставляли объект как миниатюру.
Меню кнопки «Объект» с выбором варианта «Вставить объект как миниатюра»

3. В окне файлового менеджера выберите нужный файл и нажмите кнопку Открыть.

После вставки содержимое файла будет отображаться в виде миниатюры:

  • для текстового документа будет отображаться часть первого листа, обрезанная по границам текста;
  • для таблицы — область первого листа;
  • для презентации — первый слайд.
Отображение содержимого вставленных файлов в виде миниатюр

Вставка объекта в виде иконки

Чтобы вставить объект в виде иконки:

1. Установите курсор там, куда требуется вставить объект.

2. Выполните одно из следующих действий:

  • На вкладке Вставка нажмите Файл как объект под кнопкой Файл как объект Объект и выполните команду Вставить объект как иконка;
  • На вкладке Вставка нажмите кнопку Файл как объект Объект, если в предыдущий раз вы вставляли объект как иконку.
Меню кнопки «Объект» с выбором варианта «Вставить объект как иконка»

3. В окне файлового менеджера выберите нужный файл и нажмите кнопку Открыть.

После вставки файлы будут отображаться в виде иконок:

Отображение внедренных файлов в виде иконок

Изменение содержимого объекта

Чтобы изменить содержимое объекта:

1. Выполните одно из следующих действий:

  • Дважды щелкните по объекту;
  • Выделите объект щелчком мыши и на правой боковой панели нажмите кнопку Файл как объект. На панели работы с изображениями нажмите кнопку Редактировать объект.
Кнопка «Редактировать объект» на боковой панели параметров изображения

2. В открывшемся окне редактора документов, таблиц или презентаций внесите нужные изменения. При необходимости вы можете изменить размер и положение этого окна на экране — данные параметры сохраняются для следующих сессий.

Важно

В редакторах документов, таблиц и презентаций отключен вызов справки по клавише F1.

3. Нажмите кнопку Сохранить и выйти.

Окно редактирования текстового документа с кнопкой «Сохранить и выйти»
Окно редактирования электронной таблицы с кнопкой «Сохранить и выйти»
Окно редактирования презентации с кнопкой «Сохранить и выйти»

Изменение области отображения в миниатюре таблицы

У таблицы, вставленной в виде миниатюры, можно изменить область отображения. Для этого:

1. Выполните одно из следующих действий:

  • Дважды щелкните по объекту;
  • Выделите объект щелчком мыши и на правой боковой панели нажмите кнопку Файл как объект. На панели работы с изображениями нажмите кнопку Редактировать объект.

2. В открывшемся редакторе таблиц на вкладке Вид нажмите кнопку Файл как объект.

3. Чтобы просмотреть видимую область, используйте следующие команды:

  • Показать видимую область — выделить видимую область рамкой в виде синей пунктирной линии;
  • Скрыть видимую область — скрыть рамку.

4. Чтобы изменить видимую область, выполните команду Редактировать видимую область.

Команда «Редактировать видимую область» на вкладке «Вид»

5. Для изменения размера видимой области наведите курсор на угловой маркер рамки. Когда курсор примет вид двунаправленной стрелки, зажмите левую кнопку мыши и переместите маркер.

6. Для перемещения видимой области наведите курсор на границу рамки так, чтобы он принял вид Файл как объект. Удерживая левую кнопку мыши, переместите рамку.

7. На вкладке Вид нажмите кнопку Готово.

8. Нажмите кнопку Сохранить и выйти.

Кнопка «Готово» и кнопка «Сохранить и выйти» после изменения видимой области таблицы

Сохранение объекта

Объект, внедренный в документ, можно сохранить как отдельный файл на компьютере. Для этого:

1. Выполните одно из следующих действий:

  • Дважды щелкните по объекту;
  • Выделите объект щелчком мыши и на правой боковой панели нажмите кнопку Файл как объект. На панели работы с изображениями нажмите кнопку Редактировать объект.

2. В открывшемся редакторе документов, таблиц или презентаций откройте вкладку Файл и выполните команду Сохранить как ↗.

3. Чтобы закрыть окно редактора, нажмите кнопку Сохранить и выйти.

Изменение параметров объекта

Миниатюра или иконка объекта является изображением. Вы можете изменить ее размеры ↗, стиль обтекания ↗ и положение ↗ на странице.

При необходимости к объекту можно добавить гиперссылку ↗.

Удаление объекта

Выделите объект щелчком мыши и нажмите клавишу Delete.

Была ли эта статья полезной?

Поделитесь пожалуйста своим мнением

      В статье есть ошибкиРекомендации не помоглиТекст трудно понятьСодержание статьи не соответствует заголовкуДругое