Подробнее о работе с таблицей, вставленной как OLE-объект, можно узнать в этой статье ↗.
Общая информация
Десктопная версия приложения поддерживает интеграцию в презентацию сторонних файлов в качестве самостоятельных объектов. Эта функция позволяет хранить материалы внутри одного файла и работать с ними без необходимости переключения между разными программами.
Например, в презентацию о мероприятии можно внедрить документы Программа встречи.docx и Cмета расходов.xlsx, чтобы участники могли открыть их прямо во время просмотра.
Приложение поддерживает внедрение файлов следующих популярных форматов:
- текстовые документы: DOC, DOCX;
- электронные таблицы: XLS, XLSX;
- презентации: PPT, PPTX.
Внедряемые файлы можно отображать в теле документа в виде миниатюр (для предварительного просмотра содержимого) или в виде иконок (для компактного размещения).
При вставке файл полностью интегрируется в структуру текущей презентации и становится ее частью. Связь с файлом-источником разрывается: изменения во внедренном объекте не отражаются на оригинальном файле, и наоборот.
Вставка объекта в виде миниатюры
Чтобы вставить объект как миниатюру:
- Установите курсор там, куда требуется вставить объект.
- Выполните одно из следующих действий:
- На вкладке Вставка нажмите
под кнопкой
Объект и выполните команду Вставить объект как миниатюра; - На вкладке Вставка нажмите кнопку
Объект, если в предыдущий раз вы вставляли объект как миниатюру.
Меню кнопки «Объект»
- На вкладке Вставка нажмите
- В окне файлового менеджера выберите нужный файл и нажмите кнопку Открыть.
После вставки содержимое файла будет отображаться в виде миниатюры:
- для текстового документа будет отображаться часть первого листа, обрезанная по границам текста;
- для таблицы — область первого листа;
- для презентации — первый слайд.

Вставка объекта в виде иконки
Чтобы вставить объект в виде иконки:
- Установите курсор там, куда требуется вставить объект.
- Выполните одно из следующих действий:
- На вкладке Вставка нажмите
под кнопкой
Объект и выполните команду Вставить объект как иконка; - На вкладке Вставка нажмите кнопку
Объект, если в предыдущий раз вы вставляли объект как иконку.
Меню кнопки «Объект»
- На вкладке Вставка нажмите
- В окне файлового менеджера выберите нужный файл и нажмите кнопку Открыть.
После вставки файлы будут отображаться в виде иконок.

Сохранение объекта
Объект, внедренный в документ, можно сохранить как отдельный файл на компьютере. Для этого:
- Выполните одно из следующих действий:
- Дважды щелкните по объекту.
- Выделите объект щелчком мыши и на правой боковой панели нажмите кнопку
. На панели работы с изображениями нажмите кнопку Редактировать объект.
Кнопка «Редактировать объект» на правой боковой панели
- В открывшемся редакторе документов, таблиц или презентаций откройте вкладку Файл и выполните команду Сохранить как ↗.
- Чтобы закрыть окно редактора, нажмите кнопку Сохранить и выйти.
Изменение параметров объекта
Миниатюра или иконка объекта является изображением ↗. Вы можете изменить ее размеры, стиль обтекания и положение на странице.
При необходимости к объекту можно добавить гиперссылку ↗.













