Продукты Р7
Корпоративный сервер 2024
Корпоративный сервер 2024
Сервер документов
Сервер документов
Редакторы документов
Редакторы документов
Корпоративный сервер 2019
Корпоративный сервер 2019
Графика
Графика
ВКС и мессенджер
ВКС и мессенджер
Мобильные редакторы
Мобильные редакторы
Почтовый сервер
Почтовый сервер
Органайзер
Органайзер
Сервер лицензирования
Сервер лицензирования
Файл-Экспресс
Файл-Экспресс
Аналитика
Аналитика
Дополнительно
Часто задаваемые вопросы
Разработчикам
Интеграции
Новые возможности

Проверка данных

Обновлено: 21.09.26

Инструкция актуальна для версии продукта: 2026.2.2.2683

Функция Проверка данных позволяет настраивать параметры данных, вводимые в ячейки.

  1. Чтобы получить доступ к функции проверки данных, выберите ячейку/диапазон ячеек или всю таблицу, к которой вы хотите применить эту функцию.
  2. Перейдите на вкладку Данные и нажмите кнопку Проверка данных Проверка данных. Откроется окно Проверка данных.
  3. На вкладке Настройки укажите тип и диапазон данных, которые разрешены для ввода.
Вкладка «Настройки» в окне «Проверка данных»
  • Выберите нужный вариант в выпадающем списке Разрешить:
    Важно

    Установите флаг Распространить изменения на все другие ячейки с тем же условием, чтобы использовать те же настройки для выбранного диапазона ячеек или всего листа.

    • Любое значение: без ограничений по типу данных.
    • Целое число: разрешены только целые числа.
    • Десятичное число: разрешены только десятичные дроби (числа). Дробная часть должна отделяться запятой.
    • Список: разрешены только варианты из созданного выпадающего списка. Снимите флаг с опции Показывать раскрывающийся список в ячейке, чтобы скрыть стрелку раскрывающегося списка.

      Опция «Показывать раскрывающийся список в ячейке» во вкладке «Настройки»
    • Дата: разрешены только ячейки с форматом даты.
    • Время: разрешены только ячейки с форматом времени.
    • Длина текста: устанавливает лимит символов.
    • Другое: устанавливает желаемый параметр проверки, заданный в виде формулы.
  • Укажите условие проверки в выпадающем списке Данные.
Условие проверкиОписание
МеждуДанные в ячейках должны быть в пределах диапазона, установленного правилом проверки.
Не междуДанные в ячейках НЕ должны находиться в пределах диапазона, установленного правилом проверки.
РавноДанные в ячейках должны быть равны значению, установленному правилом проверки.
Не равноДанные в ячейках НЕ должны быть равны значению, установленному правилом проверки.
БольшеДанные в ячейках должны превышать значения, установленные правилом проверки
МеньшеДанные в ячейках должны быть меньше значений, установленных правилом проверки.
Больше или равноДанные в ячейках должны быть больше или равны значению, установленному правилом проверки.
Меньше или равноДанные в ячейках должны быть меньше или равны значению, установленному правилом проверки.
  • Создайте правило проверки в зависимости от разрешенного типа данных.
Условие проверкиПравило проверкиОписаниеТип данных
Между/ не междуМинимум/МаксимумУстанавливает диапазон значенийЦелое число/Десятичное число / Длина текста
Дата начала /Дата окончанияУстанавливает диапазон датДата
Время начала/Время окончанияУстанавливает временной диапазонВремя
Равно/ не равноСравнениеУстанавливает значение для сравненияЦелое число /Десятичное число
ДатаУстанавливает дату для сравненияДата
Пройденное времяУстанавливает время для сравненияВремя
ДлинаУстанавливает значение длины текста для сравненияДлина текста
Больше/ больше или равноМинимумУстанавливает нижний пределЦелое число /Десятичное число / Длина текста
Дата началаУстанавливает дату началаДата
Время началаУстанавливает время началаВремя
Меньше/ меньше или равноМаксимумУстанавливает верхний пределЦелое число /Десятичное число / Длина текста
Дата окончанияУстанавливает дату окончанияДата
Время окончанияУстанавливает время окончанияВремя
Нет условияВ поле Источник указать ячейку/ диапазон ячеек или формулу =ДВССЫЛ(«название_таблицы»)Список
В поле Формула ввести формулу или указать ячейку, содержащую формулу для создания настраиваемого правилаДругое

4. На вкладке Подсказка по вводу создайте сообщение, которое будет отображаться при выделении ячейки, к которой применено правило.

Важно

Сообщение отображается для одной ячейки. Если будет выделен диапазон, то сообщение отобразится для первой выделенной ячейки.

Вкладка «Подсказка по вводу» в окне «Проверка данных»
  • Укажите Заголовок и текст Подсказки по вводу.
  • Снимите флаг Отображать подсказку, если ячейка является текущей, чтобы отключить отображение сообщения. Оставьте его, чтобы сообщение отображалось.

    Пример опции «Отображать подсказку, если ячейка является текущей»

5. На вкладке Сообщение об ошибке укажите сообщение, которое будет отображаться при введении данных, не соответствующих правилам проверки.

Вкладка «Сообщение об ошибке» в окне «Проверка данных»
  • Стиль: выберите стиль оповещения из доступных: Стоп, Предупреждение или Сообщение.
  • Заголовок: укажите заголовок сообщения об ошибке.
  • Сообщение об ошибке: введите текст сообщения об ошибке.
  • Снимите флаг с опции Выводить сообщение об ошибке, чтобы отключить отображение сообщения об ошибке. Оставьте его, чтобы сообщение отображалось.
Пример сообщения об ошибке

Была ли эта статья полезной?

Поделитесь пожалуйста своим мнением

      В статье есть ошибкиРекомендации не помоглиТекст трудно понятьСодержание статьи не соответствует заголовкуДругое