Продукты Р7
Корпоративный сервер 2024
Корпоративный сервер 2024
Сервер документов
Сервер документов
Редакторы документов
Редакторы документов
Корпоративный сервер 2019
Корпоративный сервер 2019
Графика
Графика
Команда
Команда
Мобильные редакторы
Мобильные редакторы
Почтовый сервер
Почтовый сервер
Органайзер
Органайзер
Сервер лицензирования
Сервер лицензирования
Файл-Экспресс
Файл-Экспресс
Аналитика
Аналитика
Дополнительно
Часто задаваемые вопросы
Разработчикам
Интеграции
Новые возможности

Совместное редактирование таблиц

Обновлено: 30.09.26

Инструкция актуальна для версии продукта: 2026.2.2.2683

В редакторе таблиц вы можете работать над таблицей совместно с другими пользователями. Эта возможность включает в себя следующие возможности:

  • одновременный многопользовательский доступ к редактируемой таблице;
  • визуальная индикация ячеек, которые редактируются другими пользователями;
  • мгновенное отображение изменений или синхронизация изменений одним нажатием кнопки;
  • чат для обмена идеями по поводу отдельных частей таблицы;
  • комментарии, содержащие описание задачи или проблемы, которую необходимо решить (работа с комментариями доступна и в автономном режиме без подключения к онлайн-версии).

Подключение к облаку

Важно

Доступно только в десктопной версии.

  1. В десктопном редакторе перейдите на вкладку Р7-ОФИС.

    Вкладка «Р7-ОФИС» в десктопном редакторе
  2. На левой панели выберите пункт меню Совместная работа.
  3. Нажмите кнопку Подключить.
  4. В окне Подключиться к облачному офису выберите облако, к которому хотите подключиться.

    Окно «Подключиться к облачному офису»
  5. Укажите адрес облака.
  6. Нажмите кнопку Подключить.
  7. В окне Войти укажите логин и пароль учётной записи.

    Окно «Войти» для ввода логина и пароля
  8. Нажмите кнопку Войти.

Подключенное облако отобразится в разделе Совместная работа. Для просмотра подключенных облаков пройдите Р7‑ОФИС → Совместная работа.

Подключенное облако в разделе «Совместная работа»

Совместное редактирование

Важно

Доступно только в онлайн-версии.

Выберите один из двух доступных режимов совместного редактирования:

  • Быстрый режим используется по умолчанию, в нём изменения, вносимые другими пользователями, отображаются в реальном времени.
  • Строгий режим позволяет скрывать изменения, внесенные другими пользователями, до тех пор, пока вы не нажмёте кнопку Совместное редактирование таблиц Сохранить, чтобы сохранить ваши изменения и принять изменения, внесенные другими пользователями.

Для смены режима перейдите на вкладку Совместная работа и нажмите кнопку Совместное редактирование таблиц Режим совместного редактирования.

Кнопка «Режим совместного редактирования»
Обратите внимание

При совместном редактировании таблицы в Быстром режиме недоступна возможность Отменить/Повторить последнее действие.

Когда таблицу редактируют одновременно несколько пользователей в Строгом режиме, редактируемые ячейки помечаются пунктирными линиями разных цветов, а ярлычок листа, на котором находятся эти ячейки, помечается красным маркером Совместное редактирование таблиц. При наведении курсора мыши на одну из редактируемых ячеек отображается имя того пользователя, который в данный момент ее редактирует. В Быстром режиме действия и имена участников совместного редактирования отображаются непосредственно в процессе редактирования данных в ячейках. В Быстром режиме диапазоны ячеек, выделенные пользователями в данный момент, также подсвечиваются границами разных цветов.

Наведите курсор мыши на выделенный диапазон, чтобы показать имя пользователя, который его редактирует.

Имя пользователя, редактирующего выделенный диапазон

Количество пользователей, которые в данный момент работают над текущей таблицей, отображается в правой части шапки редактора — Совместное редактирование таблиц Просмотр пользователей. Чтобы увидеть, кто именно редактирует файл в настоящий момент, кликните по этому значку или откройте панель Чата с полным списком пользователей.

Если файл не просматривают или не редактируют другие пользователи, кнопка Совместное редактирование таблиц Просмотр пользователей в шапке редактора отображаться не будет.

Как только один из пользователей внесёт изменения в документ, все остальные увидят в левом верхнем углу примечание, которое сообщает о наличии обновлений.

Примечание о наличии обновлений в документе

Чтобы сохранить внесенные вами изменения, сделать их доступными для других пользователей, а также получить обновления, сохраненные другими пользователями, нажмите кнопку Совместное редактирование таблиц Сохранить.

Режим просмотра в реальном времени

Важно

Опция недоступна для пользователя с ролью Аноним.

Режим просмотра в реальном времени используется для просмотра в реальном времени изменений, которые вносят другие пользователи, когда таблица открыта пользователем с правами доступа Только чтение.

Аноним

Пользователи портала, которые не зарегистрированы и не имеют профиля, считаются анонимными, хотя они по-прежнему могут совместно работать над документами.

Чат

Важно

Вкладка доступна только в онлайн-версии.

Этот инструмент можно использовать для оперативного согласования процесса совместного редактирования, например, для того, чтобы договориться с другими участниками, кто и что должен делать, какой абзац вы собираетесь сейчас отредактировать и т. д.

Сообщения в чате хранятся только в течение одной сессии. Для обсуждения содержания документа лучше использовать комментарии, которые хранятся до тех пор, пока вы не решите их удалить.

  1. Для входа в чат и переписки с пользователями перейдите на вкладку Совместное редактирование таблиц Чат на левой панели или переключитесь на вкладку Совместная работа и нажмите кнопку Совместное редактирование таблиц Чат.
  2. Введите текст в соответствующем поле ниже.

    Поле для ввода текста сообщения в чате
  3. Нажмите кнопку Отправить.

Все сообщения, оставленные пользователями, будут отображаться на панели слева. Если есть новые сообщения, которые вы еще не прочитали, то значок чата будет с жёлтой меткой Совместное редактирование таблиц.

Чтобы закрыть панель с сообщениями чата, нажмите на значок Совместное редактирование таблиц на левой панели или кнопку Совместное редактирование таблиц Чат на вкладке Совместная работа.

Комментарии

Работа с комментариями доступна в офлайн-режиме без подключения к онлайн-версии.

Создание комментария

Чтобы оставить комментарий воспользуйтесь одним из способов:

Способ 1

  1. Выделите ячейку, к которой надо оставить комментарий.
  2. На вкладке Вставка или Совместная работа нажмите кнопку Совместное редактирование таблиц Добавить комментарий.
  3. В открывшемся окне введите текст и нажмите кнопку Добавить.
Окно добавления комментария

Способ 2

  1. Кликните правой кнопкой мыши по ячейке, к которой надо оставить комментарий.
  2. В контекстном меню выберите команду Добавить комментарий.
  3. В открывшемся окне введите текст и нажмите кнопку Добавить.
Добавление комментария через контекстное меню

Способ 3

Не добавляет индикацию комментария в ячейке.

  1. Откройте вкладку Совместное редактирование таблиц Комментарии на левой панели.
  2. Нажмите ссылку Добавить комментарий к документу.
  3. Введите текст в поле для комментария и нажмите кнопку Добавить.
Окно добавления комментария

Комментарий появится на панели слева. В правом верхнем углу ячейки, к которой вы добавили комментарий, появится оранжевый треугольник (кроме способа 3). Если требуется отключить эту функцию, перейдите на вкладку Файл, выберите опцию Дополнительные параметры и снимите флаг Показывать комментарии на листе. В этом случае ячейки, к которым добавлены комментарии, будут помечаться при открытой вкладке Совместное редактирование таблиц Комментарии.

Для просмотра комментария наведите курсор на ячейку или кликните по ней. Вы или любой другой пользователь можете ответить на добавленный комментарий. Для этого нажмите на ссылку Добавить ответ, введите текст ответа в поле ввода и нажмите кнопку Ответить.

Если вы используете Строгий режим совместного редактирования, новые комментарии, добавленные другими пользователями, станут видимыми только после того, как вы нажмете на кнопку Совместное редактирование таблиц Сохранить в левом верхнем углу.

Управление комментариями

Вы можете управлять добавленными комментариями, используя значки во всплывающем окне комментария или на панели Комментарии слева:

  • отсортируйте добавленные комментарии, нажав на кнопку Совместное редактирование таблиц Сортировать комментарии на панели Комментарии:
    • по дате: От новых к старым (выбран по умолчанию) или От старых к новым.
    • по автору: По автору от А до Я или По автору от Я до А.

      Опции сортировки комментариев
  • отредактируйте выбранный комментарий, нажав кнопку Совместное редактирование таблиц Редактировать;
  • удалите выбранный комментарий, нажав кнопку Совместное редактирование таблиц Удалить.
  • для закрытия решённого комментария (задачи) нажмите кнопку Совместное редактирование таблиц Решить, после этого комментарий приобретёт статус решенного. Чтобы вновь открыть комментарий, нажмите кнопку Совместное редактирование таблиц Открыть снова.
  • если вы хотите скрыть решенные комментарии, на вкладке Файл выберите опцию Дополнительные параметры и снимите флаг Показывать решенные комментарии. В этом случае решенные комментарии будут помечаться при открытой вкладке Совместное редактирование таблиц Комментарии.
  • если вы хотите решить сразу несколько комментариев, на вкладке Совместная работа нажмите выпадающий список Решить и выберите один из вариантов решения комментариев: Решить текущие комментарии, Решить мои комментарии или Решить все комментарии.

Добавление упоминаний

Важно

1. Упоминания можно добавлять только в комментарии к тексту, а не в комментарии ко всему документу.

2. Упоминать можно только тех пользователей, которым выданы права доступа выше типа доступа Чтение.

При вводе комментариев можно использовать функцию упоминаний, которая позволяет привлечь чьё-либо внимание к комментарию и отправить оповещение упомянутому пользователю по электронной почте и в Чат.

Чтобы добавить упоминание, введите знак «+» или «@» в любом месте текста комментария — откроется список пользователей портала. Чтобы упростить процесс поиска, вы можете начать вводить имя в поле комментария — список пользователей будет меняться по мере ввода. Выберите из списка нужного человека и нажмите кнопку Добавить.

Упомянутый пользователь получит по электронной почте оповещение о том, что он был упомянут в комментарии. Если к файлу был предоставлен доступ, пользователь также получит соответствующее оповещение.

Удаление комментариев

Комментарии можно удалить одним из способов ниже.

Способ 1

Для удаления комментария нажмите кнопку Совместное редактирование таблиц Удалить на вкладке Комментарии напротив комментария, который надо удалить.

Удаление комментария на панели «Комментарии»

Способ 2

Для удаления комментария нажмите кнопку Удалить во всплывающем окне комментария на рабочем листе.

Удаление комментария во всплывающем окне на рабочем листе

Способ 3

Для удаления комментария нажмите кнопку Совместное редактирование таблиц Удалить на вкладке Совместная работа и выберите нужный пункт меню:

  • Удалить текущие комментарии — чтобы удалить выбранный комментарий. Если к комментарию были добавлены ответы, все ответы к нему также будут удалены.
  • Удалить мои комментарии — чтобы удалить добавленные вами комментарии, не удаляя комментарии, добавленные другими пользователями. Если к вашему комментарию были добавлены ответы, все ответы к нему также будут удалены.
  • Удалить все комментарии — чтобы удалить все комментарии в таблице, добавленные вами и другими пользователями.
Опции массового удаления комментариев

Чтобы закрыть панель с комментариями, нажмите на вкладку Совместное редактирование таблиц Комментарии ещё раз.

Была ли эта статья полезной?

Поделитесь пожалуйста своим мнением

      В статье есть ошибкиРекомендации не помоглиТекст трудно понятьСодержание статьи не соответствует заголовкуДругое