Продукты Р7
Корпоративный сервер 2024
Корпоративный сервер 2024
Сервер документов
Сервер документов
Редакторы
Редакторы
Корпоративный сервер 2019
Корпоративный сервер 2019
Графика
Графика
Команда
Команда
Мобильные редакторы
Мобильные редакторы
Облачный офис
Облачный офис
Почта
Почта
Органайзер
Органайзер
Дополнительно
Часто задаваемые вопросы
Разработчикам
Интеграции
Новые возможности

Ошибка сбора логов для технической поддержки: No such file or directory /root/.team/application.properties

Обновлено: 10.12.25

Описание проблемы

При попытке собрать архив логов с Медиа-сервера «Р7-Команда» с помощью скрипта из нового установочного пакета (например, версии 1.10.3 и выше), процесс завершается с ошибкой. В консоли отображается следующее сообщение:

cat: /root/.team/application.properties: No such file or directory

Рисунок 1 — ошибка при попытке собрать архив логов Медиа сервера для технической поддержки.

 

Эта ошибка возникает, когда на сервере установлена более старая версия продукта (например, 1.10.1), а для диагностики используется инструмент из более нового дистрибутива. Скрипт не может найти необходимый ему конфигурационный файл и аварийно прекращает работу.

Причина

Проблема вызвана конфликтом версий и изменением имени конфигурационного файла между релизами «Р7-Команда».

  • Версии до 1.10.3:
    Ключевые параметры для работы Медиа-сервера и служебных скриптов хранились в файле:
    /root/.team/config
  • Версии 1.10.3 и новее:
    Для унификации с общепринятыми стандартами Java-приложений, название файла было изменено на:
    /root/.team/application.properties

Решение и подробное описание проблемы

Для успешного сбора логов в такой ситуации необходимо создать для нового скрипта тот файл, который он ожидает найти, и наполнить его актуальными данными из старого конфигурационного файла, но в новом формате.

Порядок действий:

1) Авторизуйтесь на Медиа-сервере с правами суперадминистратора (например, sudo -i).

2) Просмотрите содержимое старого конфигурационного файла, чтобы скопировать его данные.

cat /root/.team/config

3) Выделите и скопируйте все содержимое этого файла.

4) Создайте новый конфигурационный файл, который ищет скрипт, с помощью текстового редактора.

nano /root/.team/application.properties

5) Вставьте скопированное на шаге 2 содержимое в открытый пустой файл. Отредактируйте названия параметров согласно новому формату.

application.config.nginx.scheme=https
application.config.nginx.servername=r7team-m-deb11.test.ru
application.config.nginx.cert=/etc/ssl/team/fullchain.pem
application.config.nginx.key=/etc/ssl/team/key.key
application.media.id=03cfc7*****caf789
application.media.token=3d9be52ad52467ee******1551c97e8131f5b4dce6c86ee4f031d794289903ed
application.media.token.hash=e922a57c8e9837e72f9*****be5c8a7446

6) Сохраните изменения (в nano: Ctrl+O, Enter) и закройте редактор (Ctrl+X).

Запустите скрипт сбора логов повторно. Теперь он успешно найдет файл application.properties и корректно выполнит свою задачу.

В случае если файл /root/.team/config по какой-либо причине отсутствует.

Сформируйте данный файл самостоятельно, для этого необходимые значения можно получить из файлов

application.media.id и application.media.token.hash из файла
cat /etc/gate/gate.conf.d/applications.conf
 
application.config.nginx.cert, application.config.nginx.key и application.config.nginx.servername из файла
cat /etc/nginx/snippets/gate.ssl
 
application.media.token можно взять из конфигурационного файла на сервере управления по пути
cat /root/.team/application.properties или /root/.team/config

Рекомендации

Для обслуживания и диагностики всегда используйте скрипты и утилиты из дистрибутива той версии, которая установлена на сервере.