Продукты Р7
Корпоративный сервер 2024
Корпоративный сервер 2024
Сервер документов
Сервер документов
Редакторы
Редакторы
Корпоративный сервер 2019
Корпоративный сервер 2019
Графика
Графика
Команда
Команда
Мобильные редакторы
Мобильные редакторы
Облачный офис
Облачный офис
Почта
Почта
Органайзер
Органайзер
Дополнительно
Часто задаваемые вопросы
Разработчикам
Интеграции
Новые возможности

При создании звонка произошла ошибка 500, Conference creation failed: fetch failed … Connect Timeout Error — Нет сетевой связности между СУ и Медиа сервером

Обновлено: 10.12.25

Описание проблемы

При попытке создать конференцию или начать звонок в «Р7-Команда», пользователи сталкиваются с критической ошибкой 500, которая прерывает процесс. В интерфейсе отображается следующее уведомление:

Рисунок 1 — ошибка на стороне WEB клиента.

 

Проверка логов на сервере управления Р7-Команда

Первым делом проверьте логи сервиса ucall_back на вашем сервере управления Р7-Команда. Запустите вывод логов в консоль.

journalctl -u ucall_back* --since "1 hours ago" --no-pager -f

Совершите попытку вызова через web клиент Р7-Команда.

В консоли появится сообщение об ошибке.

Oct 16 14:37:23 r7team ucall_back(i4)[4912]: 2025-10-16 02:10:23: ERROR POST /api/v2/conference 10.253.118.3| {"type":"TypeError","message":"fetch failed: Connect Timeout Error","stack":"TypeError: fetch failed\n    at node:internal/deps/undici/undici:12618:11\n    at process.processTicksAndRejections (node:internal/process/task_queues:95:5)\n    at async MindClient.createConference (/opt/team/back/src/infrastructure/mind/MindClientAsync.js:130:12)\n    at async CallService.create (/opt/team/back/src/service/call/CallService.js:211:17)\n    at async /opt/team/back/src/WebAPI/v2/Controllers/Conference/ConferenceController.js:36:20\ncaused by: ConnectTimeoutError: Connect Timeout Error\n    at onConnectTimeout (node:internal/deps/undici/undici:7760:28)\n    at node:internal/deps/undici/undici:7716:50\n    at Immediate._onImmediate (node:internal/deps/undici/undici:7748:13)\n    at process.processImmediate (node:internal/timers:476:21)"}
Oct 16 14:37:23 r7team ucall_back(i4)[4912]: 2025-10-16 02:10:23: INFO 500 POST /api/v2/conference  request errored {"type":"Error","message":"failed with status code 500","stack":"Error: failed with status code 500\n    at onResFinished (/opt/team/back/node_modules/pino-http/logger.js:114:39)\n    at ServerResponse.onResponseComplete (/opt/team/back/node_modules/pino-http/logger.js:177:14)\n    at ServerResponse.emit (node:events:529:35)\n    at onFinish (node:_http_outgoing:1008:10)\n    at callback (node:internal/streams/writable:555:21)\n    at afterWrite (node:internal/streams/writable:500:5)\n    at afterWriteTick (node:internal/streams/writable:487:10)\n    at processTicksAndRejections (node:internal/process/task_queues:81:21)\n    at runNextTicks (node:internal/process/task_queues:64:3)\n    at process.processImmediate (node:internal/timers:447:9)"}

Анализ логов на сервере управления «Р7-Команда» показывает ошибку тайм-аута соединения, которая является причиной сбоя:

{"type":"TypeError","message":"fetch failed: Connect Timeout Error"}

Это сообщение указывает на то, что сервер управления не смог установить сетевое соединение с медиа-сервером в отведенное время.

Причина

Проблема вызвана отсутствием сетевой связности между сервером управления и медиа-сервером. Сервер управления отправляет запрос на создание медиа-сессии, но не получает ответ, так как пакеты не доходят до медиа-сервера или ответ от него блокируется.

К этому могут приводить несколько причин:

  1. Блокировка брандмауэром: Наиболее частая причина. Трафик может блокироваться как локальным брандмауэром (ufw, firewalld) на самом медиа-сервере, так и внешним сетевым экраном, находящимся между серверами.
  2. Некорректная конфигурация сети: Ошибки в IP-адресации или масках подсети могут приводить к тому, что серверы оказываются в разных логических сетях и не могут обмениваться трафиком напрямую, даже если физически подключены к одному коммутатору.
  3. Проблемы с маршрутизацией: Если серверы находятся в разных сетях (VLAN), но между ними не настроена или некорректно работает маршрутизация, они не смогут установить соединение.

Диагностика сетевого подключения

Проверка доступности Медиа сервера с Сервера Управления (ping):

ping <IP-адрес медиа-сервера>

Если команда не проходит (нет ответов), это указывает на проблему с доступностью: блокировку ICMP-протокола файрволом, неверный IP-адрес или физическую проблему с сетью.

Проверка доступности порта (telnet). Даже если ping работает, порт 443, необходимый для взаимодействия, может быть закрыт.:

telnet media.test.com 443
# или по IP-адресу медиа-сервера
telnet <IP-адрес медиа-сервера> 443
  • Результат Connection timed out или No route to host подтверждает наличие блокировки со стороны брандмауэра или проблемы с маршрутизацией.
  • Результат Connected to <IP-адрес> означает, что порт открыт и сетевая связность на этом уровне есть.

Если проблема актуальна, вы получите ошибку: telnet: Unable to connect to remote host: Connection timed out.

Чтобы убедиться что сам медиа сервер находится в рабочем состоянии и может отвечать на https запросы выполните на медиа сервере:

# Убедитесь, что сервис доступен локально
telnet localhost 443

Решение проблемы

Проверка настроек сети и настройка брандмауэров

Локальный брандмауэр на медиа-сервере:
Подключитесь к медиа-серверу и проверьте статус его брандмауэра.

sudo ufw status

Убедитесь, что для входящего трафика на порт TCP/443 создано разрешающее правило. Если его нет, добавьте:

sudo ufw allow 443/tcp

или

sudo firewall-cmd --add-port=443/tcp --permanent
sudo firewall-cmd --reload

Внешние сетевые экраны:
Если локальный брандмауэр настроен корректно, обратитесь к сетевым администраторам для проверки правил на сетевых устройствах (маршрутизаторах, аппаратных файерволах), которые находятся между серверами.

1. Проверка сетевой конфигурации

Проверьте IP-адреса и маски подсетей на обоих серверах командой ip a. Убедитесь, что они находятся в одной логической подсети или что для них настроен корректный шлюз для взаимодействия. Ошибка в маске (например, /24 вместо /22) — частая причина подобных проблем.

2. Повторная проверка

После внесения изменений (например, добавления правила в брандмауэр) вернитесь к шагу Диагностика сетевого подключения и снова выполните команду telnet. Успешное соединение будет означать, что проблема решена.

После восстановления сетевого взаимодействия между серверами функция создания конференций в «Р7-Команда» будет работать штатно.